Your submission was sent successfully! Close

CVE-2021-30498

Published: 26 May 2021

A flaw was found in libcaca. A heap buffer overflow in export.c in function export_tga might lead to memory corruption and other potential consequences.

Priority

Medium

CVSS 3 base score: 9.8

Status

Package Release Status
libcaca
Launchpad, Ubuntu, Debian
Upstream Needs triage

Ubuntu 21.10 (Impish Indri)
Released (0.99.beta19-2.2ubuntu2.1)
Ubuntu 21.04 (Hirsute Hippo)
Released (0.99.beta19-2.2ubuntu1.1)
Ubuntu 20.04 LTS (Focal Fossa)
Released (0.99.beta19-2.1ubuntu1.20.04.2)
Ubuntu 18.04 LTS (Bionic Beaver)
Released (0.99.beta19-2ubuntu0.18.04.3)
Ubuntu 16.04 ESM (Xenial Xerus)
Released (0.99.beta19-2ubuntu0.16.04.2+esm1)
Ubuntu 14.04 ESM (Trusty Tahr)
Released (0.99.beta18-1ubuntu5.1+esm2)
Patches:
Upstream: https://github.com/cacalabs/libcaca/commit/ab04483ee1a846d6b74b2e6248e980152baec3f6